Forgot password?

Sign up
Knowledgebase: PamFax Installation
System requirements for PamFax

The following operating systems are supported by the different PamFax applications:

* Windows 7/8.x/10 (32 or 64 bit)
* Macintosh OS X (10.6 or higher)
* iPhone/iPad
* Android (Phones and Tablets)
* Windows Phone (8.1 or higher)
* Blackberry
* Any browser

Just download the PamFax application for your operating system from the download page.

Alternatively you can use PamFax via any web browser via the PamFax Portal.

Note: If you wish to receive notifications of sent and received faxes via Skype, you need the latest Skype version for Windows or Mac.

Skype is not a requirement to use PamFax.

(290 vote(s))
This article was helpful
This article was not helpful